05 August 2005

vim for the blastwave impaired

For those of you that wanted vim packaged for x86 without using blastwave. There is hope:

http://icculus.org/~eviltypeguy/pkg/vim/

You can grab the pkg along with everything build-system or source-related that I used from there. The simple instructions if you want to rebuild it your own way:


  1. Download the vim-6.3.tar.bz2 and all the other files at the URL listed above, extract the vim tarball to a build directory of your choice.

  2. Place the "copyright", "pkginfo", and "vimtopkg" files in the newly extracted directory.

  3. Edit pkginfo with your editor to match your personal info.

  4. Do a configure with something like what is below from the top level directory adding or disabling features as you please, replacing the --prefix with one of your own choosing.:
    ./configure --prefix=/opt/BCvim --with-features=huge --with-compiledby='my @ email address' --enable-perlinterp=no --enable-pythoninterp --enable-tclinterp --enable-cscope --enable-workshop --enable-multibyte --enable-xim --enable-fontset --with-x --enable-gnome-check

  5. Perform the make from the top level directory:
    make

  6. Run vimtopkg from the top level directory:
    ksh ./vimtopkg

  7. Tell it you want to use the pkginfo file.

  8. Be amazed as a complete package is written out for you ready to enjoy via pkgadd



Thanks to Phil for the original gnutopkg script that I based the vimtopkg ksh script on. I also have a more generic one suitable for packaging just about any autofoo* based program.

Technorati Tags: